树莓派中文网

 找回密码
 立即注册
搜索
热搜: 树莓派3B+
查看: 49|回复: 0

树莓派3B+安装LAMP

[复制链接]

8

主题

8

帖子

40

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
40
发表于 2019-5-21 15:46:26 | 显示全部楼层 |阅读模式
要用apt-get这种方式安装LAMP时,最好先运行下面在命令升级自己的系统这样是为了更新源,而如果你找的源不好,可能安装LMAP失败。

#sudo apt-get update 获得最近的软件包的列表;列表中包含一些包的信息,比如这个包是否更新过
#sudo apt-get dist-upgrade 如果这个包没有发布更新,就不管它;如果发布了更新,就把包下载到电脑上,并安装。

apt-get update 指令会同步使用者端和APT 伺服器的RPM 索引清单(package list),APT 伺服器的RPM 索引清单置于base 资料夹内,使用者端电脑取得base 资料夹内的bz2 RPM 索引清单压缩档后,会将其解压置放于/var/state/apt/lists/,而使用者使用apt-get install 或apt-get dist-upgrade 指令的时候,就会将这个资料夹内的资料和使用者端电脑内的RPM 资料库比对,如此一来就可以知道那些RPM 已安装、未安装、或是可以升级的。


这里提一下apt-get upgrade 与apt-get dist-upgrade的关系
由于包与包之间存在各种依赖关系。upgrade只是简单的更新包,不管这些依赖,它不和添加包,或是删除包。而dist-upgrade可以根据依赖关系的变化,添加包,删除包。

一般在运行upgrade或dist-upgrade之间,要运行update.


最后运行如下

#sudo apt-get install mysql-server

安装上mysql,其实是mariadb10.1.23

#sudo apt-get install apache2

安装apache2

#sudo apt-get install php

安装php7

#sudo apt-get install php-mysql

安装php的mysql模块

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

手机版|raspberrypi.org.cn

GMT+8, 2020-6-1 07:50 , Processed in 0.051096 second(s), 21 queries .

Powered by raspberrypi.org raspberrypi.org Array

© 2019 树莓派中文网

快速回复 返回顶部 返回列表